Have a Question? Contact Us

888-462-7828 Live Chat

McDSP Retro Pack HD V7 Bundle (Upgrade from Retro Pack HD V5)

 
  • Dale #:

    MCDS-MURPHD57
  • Availability:

    Emailed within 24 Hours
  • Within 24 hours of placing your order we will contact you by email to provide you with the details to download and authorize your software. This is not an immediate process.

Description

For registered owners of Retro Bundle HD V5. Give your tracks a little taste of yesteryear with McDSP's Retro Bundle. Available in Native or DSP versions. 4020 RETRO EQ The 4020 Retro EQ is a four-band EQ and complimentary filter set. The HF and LF bands are shelving EQs, with two additional para... Read More

Have a Question?

Call Toll Free: 888-462-7828 Live Chat Email Us

Suggested Accessories

Description

For registered owners of Retro Bundle HD V5.

Give your tracks a little taste of yesteryear with McDSP's Retro Bundle. Available in Native or DSP versions.

4020 RETRO EQ
The 4020 Retro EQ is a four-band EQ and complimentary filter set. The HF and LF bands are shelving EQs, with two additional parametric EQs at the HMF and LMF bands.

4030 RETRO COMPRESSOR
The 4030 Retro Compressor is a unique dynamic range control topology. It is coupled with a wet/dry mix control to balance compressed and uncompressed signals.

4040 RETRO LIMITER
The 4040 Retro Limiter combines a look-ahead brick wall limiter function with several subjective treatments to make the limiting action subtle, and yet vintage.

All McDSP v7 plug-ins are optimized for Apple silicon and the latest Intel Processors. If CPU efficiency is what you’re looking for, v7 is for you.
Multiple computers? No problem! With each v7 purchase, you now get two activations per license or subscription.

More +

Product Specs

McDSP V7 System Requirements
Plugin Formats AAX Native, AU, and VST3 plug-in formats.
McDSP HD plug-ins additionally support the AAX DSP plug-in format, as well as AAX Native, AU, and VST3 plug-in formats.
Mac System Requirements Mac OS 10.13.x (High Sierra), 10.14.x (Mojave), 10.15.x (Catalina), 11.x (Big Sur), 12.x (Monterey).
Mac OS version 10.12.x (Sierra) may work, but is not officially supported.
Earlier Mac OS versions are not officially supported.
Windows System Requirements Windows 10
Authorization McDSP plug-ins require an iLok2 or iLok3 USB Smart Key for authorization, or an iLok Cloud session.

More +

 

Also Popular