Contact Our Expert Sales Team:

888-462-7828

Sonnox Elite Plugin Bundle (Native AAX/VST/AU/RTAS)

  • Dale #:

    SOOX-ELITENATIVE
  • Availability:

    Emailed within 24 Hours
  • Within 24 hours of placing your order we will contact you by email to provide you with the details to download and authorize your software. This is not an immediate process.

Special Savings! Up to 75% Off!
Purchase by June 20th, 2024 and save up to 20% off standard pricing!
Selling price reflects instant savings.

Description

The Oxford Plug-ins have earned a world-class reputation for their high-quality processing, precision control and intuitive graphical interfaces. The Sonnox Elite Collection contains seven powerful mixing plug-ins used by countless professionals all over the world. Don’t waste money or time colle... Read More

Have a Question?

Call Toll Free: 888-462-7828 Live Chat Email Us

Suggested Accessories

Description

The Oxford Plug-ins have earned a world-class reputation for their high-quality processing, precision control and intuitive graphical interfaces. The Sonnox Elite Collection contains seven powerful mixing plug-ins used by countless professionals all over the world. Don’t waste money or time collecting Oxford plug-ins one by one, save a massive 40% off the individual prices, by purchasing them as the Sonnox Elite Collection.

Features:

  • Oxford EQ
  • Oxford Dynamics
  • Oxford Inflator
  • Oxford Transient Modulator
  • Oxford Reverb
  • Oxford Limiter
  • Oxford SuprEsser

More +

Product Specs

System Requirements
Pro Tools Pro Tools 10.3.8, 11.3.2, 12 – AAX Native
Pro Tools 7, 8, 9, 10 – RTAS
Approved Pro Tools CPU, OS and hardware configuration: www.avid.com
Legacy RTAS support for OS X 10.4.11 – 10.6.8 and Windows XP
iLok USB device with latest drivers
iLok2 / iLok3 required for AAX plug-ins
Audio Units Audio Units-compatible application (Logic, Digital Performer etc.)
Mac OS X 10.7 or later (for 10.15 Catalina compatibility click here)
Legacy 32-bit support for OS X 10.4.11 – 10.6.8
iLok USB device with latest drivers
iLok2 / iLok3 required for 64-bit plug-in
VST2 VST2 compatible application (Cubase, Nuendo, Sequoia etc.)
Mac OS X 10.7 or later (for 10.15 Catalina compatibility click here)
Windows 7 or later
Legacy 32-bit support for OS X 10.4.11 – 10.6.8 & Windows XP
iLok USB device with latest drivers
iLok2 / iLok3 required for 64-bit plug-in
Authorization This plug-in offers 2 activations for each product licence you own.
All licences must be kept on the same iLok account, and each activation will allow you to authorise your Plug-In using the following methods:
iLok USB device. iLok2 / iLok3 required with latest drivers
Supported Mac Hosts Pro Tools 10.3.8 – 12 (AAX Native)
Pro Tools 7 – 10 (RTAS)
Logic Pro X 10.2
Logic 8 - 9
Digital Performer
Nuendo
Cubase
Ableton
Studio 1
Supported Windows Hosts Pro Tools 10.3.8 – 12 (AAX Native)
Pro Tools 7 – 10 (RTAS)
Nuendo
Cubase
Ableton
Samplitude
Sequoia
Pyramix
Studio 1
DSP Compatibility The Oxford DeClicker does not support Avid’s TDM/HDX hardware DSP platform.
This includes Venue, S3L and S6L systems.

More +

 

Also Popular